<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData)});}}
function AddPixelById(impFullId,pixelData){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData)});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(__ez.template.isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '//ezodn.com/detroitchicago/raleigh.js?gcb=188-0&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.eurasiareview.com/xmlrpc.php" /><title>Skepticism Over Indian Godman&#039;s Claims Of COVID-19 Cure - Eurasia Review</title><link rel="stylesheet" href="https://www.eurasiareview.com/wp-content/cache/min/1/4e476328e28b19973f352562fc469171.css" data-minify="1" /><meta name="description" content="Widespread criticism has greeted Swami Ramdev&#039;s claim that his medicine has a 100 percent success rate. By Bijay Kumar Minj Popular yoga expert turned" /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.eurasiareview.com/28062020-skepticism-over-indian-godmans-claims-of-covid-19-cure/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Skepticism Over Indian Godman&#039;s Claims Of COVID-19 Cure - Eurasia Review" /><meta property="og:description" content="Widespread criticism has greeted Swami Ramdev&#039;s claim that his medicine has a 100 percent success rate. By Bijay Kumar Minj Popular yoga expert turned" /><meta property="og:url" content="https://www.eurasiareview.com/28062020-skepticism-over-indian-godmans-claims-of-covid-19-cure/" /><meta property="og:site_name" content="Eurasia Review" /><meta property="article:publisher" content="https://www.facebook.com/EurasiaReview" /><meta property="article:published_time" content="2020-06-27T23:10:07+00:00" /><meta property="article:modified_time" content="2020-06-27T23:10:10+00:00" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@EurasiaReview" /><meta name="twitter:site" content="@EurasiaReview" /> <script type="application/ld+json" class="yoast-schema-graph">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</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Eurasia Review &raquo; Feed" href="https://www.eurasiareview.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Eurasia Review &raquo; Comments Feed" href="https://www.eurasiareview.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Eurasia Review &raquo; Skepticism Over Indian Godman&#8217;s Claims Of COVID-19 Cure Comments Feed" href="https://www.eurasiareview.com/28062020-skepticism-over-indian-godmans-claims-of-covid-19-cure/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='colormag_google_fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C600&#038;ver=5.4.2&#038;display=swap' type='text/css' media='all' /><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://www.eurasiareview.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}</style> <!--[if lte IE 8]>
<script type='text/javascript' src='https://www.eurasiareview.com/wp-content/themes/colormag/js/html5shiv.min.js?ver=5.4.2'></script>
<![endif]--><link rel='https://api.w.org/' href='https://www.eurasiareview.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.eurasiareview.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.eurasiareview.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://www.eurasiareview.com/?p=224276' /><link rel="alternate" type="application/json+oembed" href="https://www.eurasiareview.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.eurasiareview.com%2F28062020-skepticism-over-indian-godmans-claims-of-covid-19-cure%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.eurasiareview.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.eurasiareview.com%2F28062020-skepticism-over-indian-godmans-claims-of-covid-19-cure%2F&#038;format=xml" /> <script type="text/javascript">var _gaq = _gaq || [];
   _gaq.push(['_setAccount', 'UA-13272849-1']);
   _gaq.push(['_trackPageview']);
   (function() {
   var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
   ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
   var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
   })();</script> <style type="text/css">.recentcomments a{display:inline!important;padding:0!important;margin:0!important}</style><style type="text/css" id="custom-background-css">body.custom-background{background-color:#fff}</style><link rel="icon" href="https://www.eurasiareview.com/wp-content/uploads/2017/03/ernew-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.eurasiareview.com/wp-content/uploads/2017/03/ernew.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.eurasiareview.com/wp-content/uploads/2017/03/ernew.png" /><meta name="msapplication-TileImage" content="https://www.eurasiareview.com/wp-content/uploads/2017/03/ernew.png" /> <style type="text/css">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</style><style type="text/css" id="wp-custom-css">author-profile-card{background:#eee;border:1px solid #ccc;padding:20px;margin-bottom:20px}.author-photo{float:left;text-align:left;padding:5px}.single .default-wp-page{display:none}.taxonomy-description{display:none}span.cat-links{display:none}</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><meta property="fb:pages" content="339585248573" /><meta name="p:domain_verify" content="41c8d94fd5f7f44fd3b12a0980be6024" /><meta name="pocket-site-verification" content="9ddf71d004ab663daa1cdce1e65bfb" />
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-143701220-3";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-143701220-3']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'eurasiareview.com']);
_gaq.push(['f._setDomainName', 'eurasiareview.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod76',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','eurasiareview.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://www.eurasiareview.com/28062020-skepticism-over-indian-godmans-claims-of-covid-19-cure/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 126435;
var ezdomain = 'eurasiareview.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":126435,"domain_test_group":20200405,"engaged_time_visit":0,"ezcache_level":2,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"66fc542e-e6ed-44f3-6167-5a36bf15c0fb","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":6,"serverid":"3.236.57.171:11316","state":"VA","t_epoch":1593301751,"template_id":126,"time_on_site_visit":0,"url":"https://www.eurasiareview.com/28062020-skepticism-over-indian-godmans-claims-of-covid-19-cure/","user_id":0,"word_count":1246,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_126435=" + new Date().getTime() + "|66fc542e-e6ed-44f3-6167-5a36bf15c0fb|false; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head><body class="post-template-default single single-post postid-224276 single-format-standard custom-background wp-custom-logo cookies-not-set wide better-responsive-menu"><div id="page" class="hfeed site"><div align="right"> ISSN 2330-717X</div><header id="masthead" class="site-header clearfix "><div id="header-text-nav-container" class="clearfix"><div class="news-bar"><div class="inner-wrap clearfix"><div class="date-in-header"> Sunday, June 28, 2020</div><div class="social-links clearfix"><ul><li><a href="https://www.facebook.com/EurasiaReview" target="_blank"><i class="fa fa-facebook"></i></a></li><li><a href="https://twitter.com/EurasiaReview" target="_blank"><i class="fa fa-twitter"></i></a></li><li><a href="https://plus.google.com/+Eurasiareview" target="_blank"><i class="fa fa-google-plus"></i></a></li><li><a href="https://www.pinterest.com/eurasiareview/" target="_blank"><i class="fa fa-pinterest"></i></a></li><li><a href="https://www.youtube.com/eurasiareview" target="_blank"><i class="fa fa-youtube"></i></a></li></ul></div></div></div><div class="inner-wrap"><div id="header-text-nav-wrap" class="clearfix"><div id="header-left-section"><div id="header-logo-image"> <a href="https://www.eurasiareview.com/" class="custom-logo-link" rel="home"><img width="250" height="125" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20250%20125'%3E%3C/svg%3E" class="custom-logo" alt="Eurasia Review" data-lazy-src="https://www.eurasiareview.com/wp-content/uploads/2020/06/cropped-newerlogo250-1.jpg" /><noscript><img width="250" height="125" src="https://www.eurasiareview.com/wp-content/uploads/2020/06/cropped-newerlogo250-1.jpg" class="custom-logo" alt="Eurasia Review" /></noscript></a></div><div id="header-text" class="screen-reader-text"><h3 id="site-title"> <a href="https://www.eurasiareview.com/" title="Eurasia Review" rel="home">Eurasia Review</a></h3><p id="site-description">A Journal of Analysis and News</p></div></div><div id="header-right-section"><div id="header-right-sidebar" class="clearfix"><aside id="text-41" class="widget widget_text clearfix"><div class="textwidget"><div id="ezoic-pub-ad-placeholder-127"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle header_responsive_1" style="display:inline-block" data-ad-client="ca-pub-7107515782730935" data-ad-slot="3824667877"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></aside></div></div></div></div><nav id="site-navigation" class="main-navigation clearfix" role="navigation"><div class="inner-wrap clearfix"><div class="home-icon"> <a href="https://www.eurasiareview.com/" title="Eurasia Review"><i class="fa fa-home"></i></a></div><p class="menu-toggle"></p><div class="menu-primary-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-85360" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-85360"><a title="World News" href="https://www.eurasiareview.com/world-news/">News</a><ul class="sub-menu"><li id="menu-item-222010" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-222010"><a href="https://www.eurasiareview.com/africa/">Africa</a></li><li id="menu-item-222013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-222013"><a href="https://www.eurasiareview.com/east-asia-pacific/">East Asia Pacific</a></li><li id="menu-item-222015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-222015"><a href="https://www.eurasiareview.com/americas/">The Americas</a></li><li id="menu-item-222009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-222009"><a title="Europe" href="https://www.eurasiareview.com/europe/">Europe</a></li><li id="menu-item-222011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-222011"><a href="https://www.eurasiareview.com/middle-east/">Middle East</a></li><li id="menu-item-222012" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-222012"><a href="https://www.eurasiareview.com/south-central-asia/">South and Central Asia</a></li></ul></li><li id="menu-item-85362" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85362"><a href="https://www.eurasiareview.com/analysis/">Analysis</a></li><li id="menu-item-85361" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85361"><a href="https://www.eurasiareview.com/opinion/">Opinion</a></li><li id="menu-item-85363" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-85363"><a href="https://www.eurasiareview.com/business-and-finance/">Business</a><ul class="sub-menu"><li id="menu-item-154670" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154670"><a href="https://www.eurasiareview.com/business-and-finance/gdkp/">GDKP</a></li></ul></li><li id="menu-item-85364" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85364"><a href="https://www.eurasiareview.com/social-issues/">Social</a></li><li id="menu-item-85365" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-85365"><a href="https://www.eurasiareview.com/religion/">Religion</a></li><li id="menu-item-85366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85366"><a href="https://www.eurasiareview.com/entertainment/">Entertainment</a></li><li id="menu-item-85367" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85367"><a href="https://www.eurasiareview.com/environment/">Environment</a></li><li id="menu-item-85368" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85368"><a href="https://www.eurasiareview.com/technology/">Technology</a></li><li id="menu-item-198258" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-198258"><a href="https://www.eurasiareview.com/science/">Science</a></li><li id="menu-item-198259" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-198259"><a href="https://www.eurasiareview.com/health/">Health</a></li><li id="menu-item-126079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-126079"><a href="https://www.eurasiareview.com/about-eurasia-review/">About Eurasia Review</a><ul class="sub-menu"><li id="menu-item-126080" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-126080"><a href="https://www.eurasiareview.com/about/">Eurasia Review&#8217;s Editorial Staff</a></li><li id="menu-item-126083" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-126083"><a href="https://www.eurasiareview.com/authors/">Authors and Partners</a></li><li id="menu-item-126082" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-126082"><a href="https://www.eurasiareview.com/submit-an-article/">Submit an Article</a></li><li id="menu-item-126179" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-126179"><a href="https://www.eurasiareview.com/buzz-future/">Buzz Future</a></li><li id="menu-item-126081" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-126081"><a href="https://www.eurasiareview.com/privacy-policy-and-terms-of-use/">Privacy Policy And Terms Of Use</a></li></ul></li><li id="menu-item-126084" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-126084"><a href="https://www.eurasiareview.com/contact/">Contact</a></li></ul></div></div></nav></div></header><div id="main" class="clearfix"><div class="inner-wrap clearfix"><div id="primary"><div id="content" class="clearfix"><article id="post-224276" class="post-224276 post type-post status-publish format-standard has-post-thumbnail hentry category-567 category-religion category-south-central-asia"><div class="featured-image"> <img width="800" height="445" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20800%20445'%3E%3C/svg%3E" class="attachment-colormag-featured-image size-colormag-featured-image wp-post-image" alt="Yoga guru Baba Ramdev speaks on a television program in New Delhi on Sept. 16, 2018. (Photo: IANS/UCA News)" data-lazy-srcset="https://www.eurasiareview.com/wp-content/uploads/2020/06/c-100.jpg 800w, https://www.eurasiareview.com/wp-content/uploads/2020/06/c-100-300x167.jpg 300w, https://www.eurasiareview.com/wp-content/uploads/2020/06/c-100-768x427.jpg 768w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://www.eurasiareview.com/wp-content/uploads/2020/06/c-100.jpg" /><noscript><img width="800" height="445" src="https://www.eurasiareview.com/wp-content/uploads/2020/06/c-100.jpg" class="attachment-colormag-featured-image size-colormag-featured-image wp-post-image" alt="Yoga guru Baba Ramdev speaks on a television program in New Delhi on Sept. 16, 2018. (Photo: IANS/UCA News)" srcset="https://www.eurasiareview.com/wp-content/uploads/2020/06/c-100.jpg 800w, https://www.eurasiareview.com/wp-content/uploads/2020/06/c-100-300x167.jpg 300w, https://www.eurasiareview.com/wp-content/uploads/2020/06/c-100-768x427.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></noscript> <em><p class="caption" align="left">Yoga guru Baba Ramdev speaks on a television program in New Delhi on Sept. 16, 2018. (Photo: IANS/UCA News)</p></em></div><div class="article-content clearfix"><div class="above-entry-meta"><span class="cat-links"><a href="https://www.eurasiareview.com/1/" style="background:#ffffff" rel="category tag">1</a>&nbsp;<a href="https://www.eurasiareview.com/religion/" style="background:#eded02" rel="category tag">Religion</a>&nbsp;<a href="https://www.eurasiareview.com/south-central-asia/" rel="category tag">South and Central Asia</a>&nbsp;</span></div><header class="entry-header"><h1 class="entry-title"> Skepticism Over Indian Godman&#8217;s Claims Of COVID-19 Cure</h1></header><div class="below-entry-meta"> <span class="posted-on"><a href="https://www.eurasiareview.com/28062020-skepticism-over-indian-godmans-claims-of-covid-19-cure/" title="1:10 am" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2020-06-28T01:10:07+02:00">June 28, 2020</time><time class="updated" datetime="2020-06-28T01:10:10+02:00">June 28, 2020</time></a></span> <span class="byline"> <span class="author vcard"> <i class="fa fa-user"></i> <a class="url fn n" href="https://www.eurasiareview.com/author/ucan/" title="UCAN">UCAN </a> </span> </span> <span class="comments"><a href="https://www.eurasiareview.com/28062020-skepticism-over-indian-godmans-claims-of-covid-19-cure/#respond"><i class="fa fa-comment"></i> 0 Comments</a></span></div><p>By <a href="https://www.eurasiareview.com/author/ucan/" title="Posts by UCAN" class="author url fn" rel="author">UCAN</a></p><div class="entry-content clearfix"><div id="ezoic-pub-ad-placeholder-102"><div style="clear: both; margin-top: 0px; margin-right: 15px; margin-bottom: 10px; margin-left: 0px; float: left;"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7107515782730935" data-ad-slot="8263607075"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div> <a data-pocket-label="pocket" data-pocket-count="none" class="pocket-btn" data-lang="en"></a> <p>Widespread criticism has greeted Swami Ramdev&#8217;s claim that his medicine has a 100 percent success rate.</p><p>By Bijay Kumar Minj</p><p>Popular yoga expert turned businessmen Swami Ramdev has claimed that his Patanjali Ayurved company has successfully produced a medicine named Coronil that can cure Covid-19.</p><p>“It has a 100 percent success rate,” said Swami Ramdev, better known as Baba Ramdev, during the launch of the product at a press conference at Patanjali&#8217;s headquarters in Haridwar, Uttarakhand, on June 23.</p><p>“Baba Ramdev is claiming to have found a medicine to treat Covid-19 but it is not clinically proven,” Father Julius Amla, secretary for the Indian Catholic Bishops’ Conference’s office of health, told UCA News.</p><p>“When the entire world is fighting the pandemic and trying to find a vaccine for the disease, some people may claim to have come up with a medicine that can cure the disease, but people must be alert because they can be misled and given false hope.</p><div class="9g0uHVMf"><div id="ezoic-pub-ad-placeholder-110"><div style="display:block;float:left;margin-bottom:5px;margin-right:5px;"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7107515782730935" data-ad-slot="8800050277"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div><p>“People are in a panic and desperately looking for a cure, so some people can exploit that. It is better we wait until we have the solution to this life-threatening disease.”</p><p>Ramdev said the research was done by a joint team of Patanjali Research Institute and the National Institute of Medical Sciences in Jaipur.“The medicine kit will include Coronil, Shwasari and Anu Tel and will be available on the market soon,” Ramdev said without giving the exact date of sale.</p><p>Shripad Naik, who heads the Ministry of Ayurveda, Yoga and Naturopathy, Unani, Siddha and Homoeopathy (Ayush), said it is good that Ramdev has given the new medicine to the country but it needs clearance from his ministry.</p><p>He said anyone is free to make a medicine but they have to send details of the research to the ministry for confirmation. Patanjali has been told to stop advertising until the research is confirmed by the ministry.</p><p>After Patanjali&#8217;s publicised launch, the Ayush ministry asked for details of the Coronil cure kit and the trials it claimed to have conducted.</p><p>The state government of Uttarakhand, where Patanjali Ayurved is based, told ANI news agency that Ramdev did not mention his company was developing a drug for the coronavirus when it applied for a license.</p><p>The state government sought clarification over its claim of having developed a cure for Covid-19 and asked it to stop advertising the product until the claim is verified.</p><p>“We only approved the license for an immunity booster, cough and fever,” a licensing officer of the state’s Ayurveda department was quoted as saying by ANI.</p><p>However, the official said the government will issue a notice asking how they got permission to make the kit.</p><p>Meanwhile, Ramdev claimed they conducted the study on 95 patients and within three days 69 percent had recovered and within seven days 100 percent tested negative.</p><p>He also said during the launch that the medicine had cleared clinical trials in several cities. However, the company did not release any clinical testing data.</p><p>“It is still to be confirmed if Baba Ramdev&#8217;s Coronil has conformed to the norms required such as protocols and clinical trials,”  Joseph Dias, founder of the Mumbai-based Catholic Secular Forum, told UCA News.</p><p>“Unless it is approved and tested widely among Covid-positive cases, it is not correct to say a cure has been found. In the age of modern medicine, even developed countries and multinational companies who have been researching have not found a cure yet. Hence, Baba Ramdev&#8217;s Coronil is bound to be viewed suspiciously as fake,” the priest said.</p><p>Patient details, Covid stage, sample size, whether patients were properly tested and monitored and whether other medications were taken are just a few concerns awaiting clarification.</p><p>“Unless all details regarding Coronil are made public and subject to open critical scrutiny, Baba Ramdev will be seen to be trying to make a fast buck, taking advantage of the pandemic conditions,” Dias added.</p></div></div><p id="breadcrumbs"><span><span><a href="https://www.eurasiareview.com/">Home</a> » <span class="breadcrumb_last" aria-current="page">Skepticism Over Indian Godman&#8217;s Claims Of COVID-19 Cure</span></span></span></p></article></div><ul class="default-wp-page clearfix"><li class="previous"><a href="https://www.eurasiareview.com/28062020-russias-social-constitution-council-calls-on-putin-to-postpone-referendum-vote-oped/" rel="prev"><span class="meta-nav">&larr;</span> Russia&#8217;s Social Constitution Council Calls On Putin To Postpone Referendum Vote &#8211; OpEd</a></li><li class="next"></li></ul><div class="author-box"><div class="author-img"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" width="100" height="100" alt="UCAN" class="avatar avatar-100 wp-user-avatar wp-user-avatar-100 alignnone photo" data-lazy-src="https://www.eurasiareview.com/wp-content/uploads/2015/08/UCANews-128x128.jpg" /><noscript><img src="https://www.eurasiareview.com/wp-content/uploads/2015/08/UCANews-128x128.jpg" width="100" height="100" alt="UCAN" class="avatar avatar-100 wp-user-avatar wp-user-avatar-100 alignnone photo" /></noscript></div><h4 class="author-name">UCAN</h4><p class="author-description">The Union of Catholic Asian News (UCA News, UCAN) is the leading independent Catholic news source in Asia. A network of journalists and editors that spans East, South and Southeast Asia, UCA News has for four decades aimed to provide the most accurate and up-to-date news, feature, commentary and analysis, and multimedia content on social, political and religious developments that relate or are of interest to the Catholic Church in Asia.</p></div><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/28062020-skepticism-over-indian-godmans-claims-of-covid-19-cure/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.eurasiareview.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='224276' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7685f1ec3f" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="100" /></p></form></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></div><div id="secondary"><aside id="text-45" class="widget widget_text clearfix"><h3 class="widget-title"><span>Search</span></h3><div class="textwidget"><p><br /> <gcse:searchbox-only></gcse:searchbox-only></p></div></aside><aside id="colormag_featured_posts_vertical_widget-22" class="widget widget_featured_posts widget_featured_posts_vertical widget_featured_meta clearfix"><h3 class="widget-title"><span>Recent</span></h3><div class="first-post"><div class="single-article clearfix"><figure><a href="https://www.eurasiareview.com/28062020-skepticism-over-indian-godmans-claims-of-covid-19-cure/" title="Skepticism Over Indian Godman&#8217;s Claims Of COVID-19 Cure"><img width="390" height="205" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20390%20205'%3E%3C/svg%3E" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="Yoga guru Baba Ramdev speaks on a television program in New Delhi on Sept. 16, 2018. (Photo: IANS/UCA News)" title="Skepticism Over Indian Godman&#8217;s Claims Of COVID-19 Cure" data-lazy-src="https://www.eurasiareview.com/wp-content/uploads/2020/06/c-100-390x205.jpg" /><noscript><img width="390" height="205" src="https://www.eurasiareview.com/wp-content/uploads/2020/06/c-100-390x205.jpg" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="Yoga guru Baba Ramdev speaks on a television program in New Delhi on Sept. 16, 2018. (Photo: IANS/UCA News)" title="Skepticism Over Indian Godman&#8217;s Claims Of COVID-19 Cure" /></noscript></a></figure><div class="article-content"><div class="above-entry-meta"><span class="cat-links"><a href="https://www.eurasiareview.com/1/" style="background:#ffffff" rel="category tag">1</a>&nbsp;<a href="https://www.eurasiareview.com/religion/" style="background:#eded02" rel="category tag">Religion</a>&nbsp;<a href="https://www.eurasiareview.com/south-central-asia/" rel="category tag">South and Central Asia</a>&nbsp;</span></div><h3 class="entry-title"> <a href="https://www.eurasiareview.com/28062020-skepticism-over-indian-godmans-claims-of-covid-19-cure/" title="Skepticism Over Indian Godman&#8217;s Claims Of COVID-19 Cure">Skepticism Over Indian Godman&#8217;s Claims Of COVID-19 Cure</a></h3><div class="below-entry-meta"> <span class="posted-on"><a href="https://www.eurasiareview.com/28062020-skepticism-over-indian-godmans-claims-of-covid-19-cure/" title="1:10 am" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2020-06-28T01:10:07+02:00">June 28, 2020</time><time class="updated" datetime="2020-06-28T01:10:10+02:00">June 28, 2020</time></a></span> <span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="https://www.eurasiareview.com/author/ucan/" title="UCAN">UCAN</a></span></span> <span class="comments"><i class="fa fa-comment"></i><a href="https://www.eurasiareview.com/28062020-skepticism-over-indian-godmans-claims-of-covid-19-cure/#respond">0</a></span></div><div class="entry-content"><p>Widespread criticism has greeted Swami Ramdev&#8217;s claim that his medicine has a 100 percent success rate. By Bijay Kumar Minj</p></div></div></div></div><div class="following-post"><div class="single-article clearfix"><figure><a href="https://www.eurasiareview.com/28062020-russias-social-constitution-council-calls-on-putin-to-postpone-referendum-vote-oped/" title="Russia&#8217;s Social Constitution Council Calls On Putin To Postpone Referendum Vote &#8211; OpEd"><img width="130" height="90" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20130%2090'%3E%3C/svg%3E" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="vladimir putin russia flag" title="Russia&#8217;s Social Constitution Council Calls On Putin To Postpone Referendum Vote &#8211; OpEd" data-lazy-srcset="https://www.eurasiareview.com/wp-content/uploads/2020/01/a-19-130x90.jpg 130w, https://www.eurasiareview.com/wp-content/uploads/2020/01/a-19-392x272.jpg 392w" data-lazy-sizes="(max-width: 130px) 100vw, 130px" data-lazy-src="https://www.eurasiareview.com/wp-content/uploads/2020/01/a-19-130x90.jpg" /><noscript><img width="130" height="90" src="https://www.eurasiareview.com/wp-content/uploads/2020/01/a-19-130x90.jpg" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="vladimir putin russia flag" title="Russia&#8217;s Social Constitution Council Calls On Putin To Postpone Referendum Vote &#8211; OpEd" srcset="https://www.eurasiareview.com/wp-content/uploads/2020/01/a-19-130x90.jpg 130w, https://www.eurasiareview.com/wp-content/uploads/2020/01/a-19-392x272.jpg 392w" sizes="(max-width: 130px) 100vw, 130px" /></noscript></a></figure><div class="article-content"><div class="above-entry-meta"><span class="cat-links"><a href="https://www.eurasiareview.com/1/" style="background:#ffffff" rel="category tag">1</a>&nbsp;<a href="https://www.eurasiareview.com/europe/" rel="category tag">Europe</a>&nbsp;<a href="https://www.eurasiareview.com/opinion/" style="background:#16868e" rel="category tag">Opinion</a>&nbsp;</span></div><h3 class="entry-title"> <a href="https://www.eurasiareview.com/28062020-russias-social-constitution-council-calls-on-putin-to-postpone-referendum-vote-oped/" title="Russia&#8217;s Social Constitution Council Calls On Putin To Postpone Referendum Vote &#8211; OpEd">Russia&#8217;s Social Constitution Council Calls On Putin To Postpone Referendum Vote &#8211; OpEd</a></h3><div class="below-entry-meta"> <span class="posted-on"><a href="https://www.eurasiareview.com/28062020-russias-social-constitution-council-calls-on-putin-to-postpone-referendum-vote-oped/" title="1:01 am" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2020-06-28T01:01:38+02:00">June 28, 2020</time><time class="updated" datetime="2020-06-28T01:01:41+02:00">June 28, 2020</time></a></span> <span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="https://www.eurasiareview.com/author/paul-goble/" title="Paul Goble">Paul Goble</a></span></span> <span class="comments"><i class="fa fa-comment"></i><a href="https://www.eurasiareview.com/28062020-russias-social-constitution-council-calls-on-putin-to-postpone-referendum-vote-oped/#respond">0</a></span></div></div></div><div class="single-article clearfix"><figure><a href="https://www.eurasiareview.com/28062020-okinawa-governor-refuses-to-host-us-nuclear-missiles/" title="Okinawa Governor Refuses To Host US Nuclear Missiles"><img width="130" height="90" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20130%2090'%3E%3C/svg%3E" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Governor Tamaki (right) with U.S. Marines stationed in Okinawa (2019). Public domain | Source: Wikimedia Commons" title="Okinawa Governor Refuses To Host US Nuclear Missiles" data-lazy-srcset="https://www.eurasiareview.com/wp-content/uploads/2020/06/c-99-130x90.jpg 130w, https://www.eurasiareview.com/wp-content/uploads/2020/06/c-99-392x272.jpg 392w" data-lazy-sizes="(max-width: 130px) 100vw, 130px" data-lazy-src="https://www.eurasiareview.com/wp-content/uploads/2020/06/c-99-130x90.jpg" /><noscript><img width="130" height="90" src="https://www.eurasiareview.com/wp-content/uploads/2020/06/c-99-130x90.jpg" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Governor Tamaki (right) with U.S. Marines stationed in Okinawa (2019). Public domain | Source: Wikimedia Commons" title="Okinawa Governor Refuses To Host US Nuclear Missiles" srcset="https://www.eurasiareview.com/wp-content/uploads/2020/06/c-99-130x90.jpg 130w, https://www.eurasiareview.com/wp-content/uploads/2020/06/c-99-392x272.jpg 392w" sizes="(max-width: 130px) 100vw, 130px" /></noscript></a></figure><div class="article-content"><div class="above-entry-meta"><span class="cat-links"><a href="https://www.eurasiareview.com/1/" style="background:#ffffff" rel="category tag">1</a>&nbsp;<a href="https://www.eurasiareview.com/east-asia-pacific/" rel="category tag">East Asia Pacific</a>&nbsp;<a href="https://www.eurasiareview.com/social-issues/" style="background:#ddbcbc" rel="category tag">Social Issues</a>&nbsp;</span></div><h3 class="entry-title"> <a href="https://www.eurasiareview.com/28062020-okinawa-governor-refuses-to-host-us-nuclear-missiles/" title="Okinawa Governor Refuses To Host US Nuclear Missiles">Okinawa Governor Refuses To Host US Nuclear Missiles</a></h3><div class="below-entry-meta"> <span class="posted-on"><a href="https://www.eurasiareview.com/28062020-okinawa-governor-refuses-to-host-us-nuclear-missiles/" title="12:57 am" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2020-06-28T00:57:47+02:00">June 28, 2020</time><time class="updated" datetime="2020-06-28T00:57:50+02:00">June 28, 2020</time></a></span> <span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="https://www.eurasiareview.com/author/idn/" title="IDN">IDN</a></span></span> <span class="comments"><i class="fa fa-comment"></i><a href="https://www.eurasiareview.com/28062020-okinawa-governor-refuses-to-host-us-nuclear-missiles/#respond">0</a></span></div></div></div><div class="single-article clearfix"><figure><a href="https://www.eurasiareview.com/28062020-air-pollution-could-help-london-transport-planners-fight-covid-19/" title="Air Pollution Could Help London Transport Planners Fight COVID-19"><img width="130" height="90" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20130%2090'%3E%3C/svg%3E" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="traffic taxis London United Kingdom" title="Air Pollution Could Help London Transport Planners Fight COVID-19" data-lazy-srcset="https://www.eurasiareview.com/wp-content/uploads/2017/06/a-38-130x90.jpg 130w, https://www.eurasiareview.com/wp-content/uploads/2017/06/a-38-392x272.jpg 392w" data-lazy-sizes="(max-width: 130px) 100vw, 130px" data-lazy-src="https://www.eurasiareview.com/wp-content/uploads/2017/06/a-38-130x90.jpg" /><noscript><img width="130" height="90" src="https://www.eurasiareview.com/wp-content/uploads/2017/06/a-38-130x90.jpg" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="traffic taxis London United Kingdom" title="Air Pollution Could Help London Transport Planners Fight COVID-19" srcset="https://www.eurasiareview.com/wp-content/uploads/2017/06/a-38-130x90.jpg 130w, https://www.eurasiareview.com/wp-content/uploads/2017/06/a-38-392x272.jpg 392w" sizes="(max-width: 130px) 100vw, 130px" /></noscript></a></figure><div class="article-content"><div class="above-entry-meta"><span class="cat-links"><a href="https://www.eurasiareview.com/1/" style="background:#ffffff" rel="category tag">1</a>&nbsp;<a href="https://www.eurasiareview.com/environment/" style="background:#81d742" rel="category tag">Environment</a>&nbsp;<a href="https://www.eurasiareview.com/europe/" rel="category tag">Europe</a>&nbsp;</span></div><h3 class="entry-title"> <a href="https://www.eurasiareview.com/28062020-air-pollution-could-help-london-transport-planners-fight-covid-19/" title="Air Pollution Could Help London Transport Planners Fight COVID-19">Air Pollution Could Help London Transport Planners Fight COVID-19</a></h3><div class="below-entry-meta"> <span class="posted-on"><a href="https://www.eurasiareview.com/28062020-air-pollution-could-help-london-transport-planners-fight-covid-19/" title="12:54 am" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2020-06-28T00:54:01+02:00">June 28, 2020</time><time class="updated" datetime="2020-06-28T00:54:04+02:00">June 28, 2020</time></a></span> <span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="https://www.eurasiareview.com/author/admin/" title="Eurasia Review">Eurasia Review</a></span></span> <span class="comments"><i class="fa fa-comment"></i><a href="https://www.eurasiareview.com/28062020-air-pollution-could-help-london-transport-planners-fight-covid-19/#respond">0</a></span></div></div></div><div class="single-article clearfix"><figure><a href="https://www.eurasiareview.com/28062020-turkmenistan-denies-apparent-covid-19-outbreak-says-hrw/" title="Turkmenistan Denies Apparent COVID-19 Outbreak, Says HRW"><img width="130" height="90" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20130%2090'%3E%3C/svg%3E" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Location of Turkmenistan. Source: CIA World Factbook." title="Turkmenistan Denies Apparent COVID-19 Outbreak, Says HRW" data-lazy-srcset="https://www.eurasiareview.com/wp-content/uploads/2015/08/Location-of-Turkmenistan-130x90.jpg 130w, https://www.eurasiareview.com/wp-content/uploads/2015/08/Location-of-Turkmenistan-392x272.jpg 392w" data-lazy-sizes="(max-width: 130px) 100vw, 130px" data-lazy-src="https://www.eurasiareview.com/wp-content/uploads/2015/08/Location-of-Turkmenistan-130x90.jpg" /><noscript><img width="130" height="90" src="https://www.eurasiareview.com/wp-content/uploads/2015/08/Location-of-Turkmenistan-130x90.jpg" class="attachment-colormag-featured-post-small size-colormag-featured-post-small wp-post-image" alt="Location of Turkmenistan. Source: CIA World Factbook." title="Turkmenistan Denies Apparent COVID-19 Outbreak, Says HRW" srcset="https://www.eurasiareview.com/wp-content/uploads/2015/08/Location-of-Turkmenistan-130x90.jpg 130w, https://www.eurasiareview.com/wp-content/uploads/2015/08/Location-of-Turkmenistan-392x272.jpg 392w" sizes="(max-width: 130px) 100vw, 130px" /></noscript></a></figure><div class="article-content"><div class="above-entry-meta"><span class="cat-links"><a href="https://www.eurasiareview.com/1/" style="background:#ffffff" rel="category tag">1</a>&nbsp;<a href="https://www.eurasiareview.com/health/" style="background:#2c4e93" rel="category tag">Health</a>&nbsp;<a href="https://www.eurasiareview.com/social-issues/" style="background:#ddbcbc" rel="category tag">Social Issues</a>&nbsp;<a href="https://www.eurasiareview.com/south-central-asia/" rel="category tag">South and Central Asia</a>&nbsp;</span></div><h3 class="entry-title"> <a href="https://www.eurasiareview.com/28062020-turkmenistan-denies-apparent-covid-19-outbreak-says-hrw/" title="Turkmenistan Denies Apparent COVID-19 Outbreak, Says HRW">Turkmenistan Denies Apparent COVID-19 Outbreak, Says HRW</a></h3><div class="below-entry-meta"> <span class="posted-on"><a href="https://www.eurasiareview.com/28062020-turkmenistan-denies-apparent-covid-19-outbreak-says-hrw/" title="12:50 am" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2020-06-28T00:50:22+02:00">June 28, 2020</time><time class="updated" datetime="2020-06-28T00:50:25+02:00">June 28, 2020</time></a></span> <span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="https://www.eurasiareview.com/author/admin/" title="Eurasia Review">Eurasia Review</a></span></span> <span class="comments"><i class="fa fa-comment"></i><a href="https://www.eurasiareview.com/28062020-turkmenistan-denies-apparent-covid-19-outbreak-says-hrw/#respond">0</a></span></div></div></div></div></aside><aside id="text-42" class="widget widget_text clearfix"><div class="textwidget"><div id="ezoic-pub-ad-placeholder-106"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-7107515782730935" data-ad-slot="7016981075"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></aside><aside id="text-47" class="widget widget_text clearfix"><h3 class="widget-title"><span>Eurasia Review Newsletter</span></h3><div class="textwidget"><p>Get Eurasia Review’s insightful news, analysis and opinion delivered directly to your email. Sign up <a href="https://feedburner.google.com/fb/a/mailverify?uri=eurasiareview/VsnE">here to get our free newsletter</a> delivered directly to your inbox.</p><p>Make sure to check your email to confirm your subscription.</p></div></aside><aside id="recent-comments-4" class="widget widget_recent_comments clearfix"><h3 class="widget-title"><span>Recent Comments</span></h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Mahesh Mikki</span> on <a href="https://www.eurasiareview.com/27062020-policing-irrelevant-for-public-safety-here-are-some-alternatives-that-are-proven-to-work-oped/#comment-828194">Policing Irrelevant for Public Safety: Here Are Some Alternatives That Are Proven To Work &#8211; OpEd</a></li><li class="recentcomments"><span class="comment-author-link">ROBERT MATTHIAS</span> on <a href="https://www.eurasiareview.com/27062020-the-second-round-of-lockdowns-wont-be-as-easy-as-the-first-oped/#comment-828187">The Second Round Of Lockdowns Won&#8217;t Be As Easy As The First &#8211; OpEd</a></li><li class="recentcomments"><span class="comment-author-link">David McBride</span> on <a href="https://www.eurasiareview.com/27062020-wasteful-secret-and-vicious-absurd-prosecution-of-witness-k-and-bernard-collaery-oped/#comment-828167">Wasteful, Secret And Vicious: Absurd Prosecution Of Witness K And Bernard Collaery &#8211; OpEd</a></li><li class="recentcomments"><span class="comment-author-link">Jose Jr. Bandiwan</span> on <a href="https://www.eurasiareview.com/28112019-lets-stop-cutting-pine-trees-in-our-city-oped/#comment-828161">Let&#8217;s Stop Cutting Pine Trees in Our City &#8211; OpEd</a></li><li class="recentcomments"><span class="comment-author-link">charles schenck</span> on <a href="https://www.eurasiareview.com/26062020-why-climate-activists-will-go-nuclear-or-go-extinct-oped/#comment-828159">Why Climate Activists Will Go Nuclear, Or Go Extinct &#8211; OpEd</a></li></ul></aside><aside id="custom_html-3" class="widget_text widget widget_custom_html clearfix"><h3 class="widget-title"><span>Please Donate Today</span></h3><div class="textwidget custom-html-widget"><p> Did you enjoy this article? Then please consider donating today to ensure that Eurasia Review can continue to be able to provide similar content.</p><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"> <input type="hidden" name="cmd" value="_s-xclick" /> <input type="hidden" name="hosted_button_id" value="FLR6KLQ89SCA6" /> <input type="image" src="https://www.paypalobjects.com/en_US/i/btn/btn_donateCC_LG.gif" border="0" name="submit" title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" /> <img alt="" border="0" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" width="1" height="1" data-lazy-src="https://www.paypal.com/en_US/i/scr/pixel.gif" /><noscript><img alt="" border="0" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" /></noscript></form></div></aside></div></div></div><footer id="colophon" class="clearfix "><div class="footer-socket-wrapper clearfix"><div class="inner-wrap"><div class="footer-socket-area"><div class="footer-socket-right-section"><div class="social-links clearfix"><ul><li><a href="https://www.facebook.com/EurasiaReview" target="_blank"><i class="fa fa-facebook"></i></a></li><li><a href="https://twitter.com/EurasiaReview" target="_blank"><i class="fa fa-twitter"></i></a></li><li><a href="https://plus.google.com/+Eurasiareview" target="_blank"><i class="fa fa-google-plus"></i></a></li><li><a href="https://www.pinterest.com/eurasiareview/" target="_blank"><i class="fa fa-pinterest"></i></a></li><li><a href="https://www.youtube.com/eurasiareview" target="_blank"><i class="fa fa-youtube"></i></a></li></ul></div></div><div class="footer-socket-left-section"><div class="copyright"> Copyright <span>Eurasia Review.</span> All rights are reserved.</div></div></div></div></div></footer> <a href="#masthead" id="scroll-up"><i class="fa fa-chevron-up"></i></a></div> <script type='text/javascript'>/* <![CDATA[ */ var cnArgs = {"ajaxUrl":"https:\/\/www.eurasiareview.com\/wp-admin\/admin-ajax.php","nonce":"8602dd4c6f","hideEffect":"fade","position":"bottom","onScroll":"0","onScrollOffset":"100","onClick":"0","cookieName":"cookie_notice_accepted","cookieTime":"2592000","cookieTimeRejected":"2592000","cookiePath":"\/","cookieDomain":"","redirection":"0","cache":"1","refuse":"1","revokeCookies":"0","revokeCookiesOpt":"automatic","secure":"1","coronabarActive":"0"}; /* ]]> */</script> <div id="cookie-notice" role="banner" class="cookie-notice-hidden cookie-revoke-hidden cn-position-bottom" aria-label="Cookie Notice" style="background-color: rgba(0,0,0,1);"><div class="cookie-notice-container" style="color: #fff;"><span id="cn-notice-text" class="cn-text-container">We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.</span><span id="cn-notice-buttons" class="cn-buttons-container"><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie cn-button bootstrap" aria-label="Ok">Ok</a><a href="#" id="cn-refuse-cookie" data-cookie-set="refuse" class="cn-set-cookie cn-button bootstrap" aria-label="No">No</a><a href="https://www.eurasiareview.com/privacy-policy-and-terms-of-use/" target="_blank" id="cn-more-info" class="cn-more-info cn-button bootstrap" aria-label="Privacy policy">Privacy policy</a></span><a href="javascript:void(0);" id="cn-close-notice" data-cookie-set="accept" class="cn-close-icon" aria-label="Ok"></a></div></div> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.eurasiareview.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script src="https://www.eurasiareview.com/wp-content/cache/min/1/680c8353f1285612d946d2c258830383.js" data-minify="1" defer></script><script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=33', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=33', false, [], true, false, false, false);
</script>
<script>var _audins_dom="eurasiareview_com",_audins_did=126435;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.eurasiareview_com,DomainId.126435" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body></html>
